suggests: Declare when Suggested Packages are Needed

By adding dependencies to the "Suggests" field of a package's DESCRIPTION file, and then declaring that they are needed within any dependent functionality, it is often possible to significantly reduce the number of "hard" dependencies required by a package. This package provides a minimal way to declare when a suggested package is needed.

Version: 0.1.0
Imports: utils
Suggests: covr, testthat (≥ 3.0.0)
Published: 2023-08-08
Author: Owen Jones ORCID iD [aut, cre]
Maintainer: Owen Jones <owenjonesuob at gmail.com>
BugReports: https://github.com/owenjonesuob/suggests/issues
License: MIT + file LICENSE
URL: https://github.com/owenjonesuob/suggests
NeedsCompilation: no
Materials: README NEWS
CRAN checks: suggests results

Documentation:

Reference manual: suggests.pdf

Downloads:

Package source: suggests_0.1.0.tar.gz
Windows binaries: r-prerel: suggests_0.1.0.zip, r-release: suggests_0.1.0.zip, r-oldrel: suggests_0.1.0.zip
macOS binaries: r-prerel (arm64): suggests_0.1.0.tgz, r-release (arm64): suggests_0.1.0.tgz, r-oldrel (arm64): suggests_0.1.0.tgz, r-prerel (x86_64): suggests_0.1.0.tgz, r-release (x86_64): suggests_0.1.0.tgz

Linking:

Please use the canonical form https://CRAN.R-project.org/package=suggests to link to this page.